package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<p>@@@LINK=(.+?)</p>`)
var str = `<p>@@@LINK=ten pence</p>
<p>@@@LINK=twenty-twenty vision</p>
<p>@@@LINK=fifty pence</p>
<p>@@@LINK=abate</p>`
var substitution = "<a href="x-dictionary:d:\g<1>:dict_bundle_id">\g<1></a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}