# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p>@@@LINK=(.+?)</p>"
test_str = ("<p>@@@LINK=ten pence</p>\n"
"<p>@@@LINK=twenty-twenty vision</p>\n"
"<p>@@@LINK=fifty pence</p>\n"
"<p>@@@LINK=abate</p>")
subst = "<a href=\"x-dictionary:d:\\g<1>:dict_bundle_id\">\\g<1></a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.