const regex = /a(?=\w*i)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a(?=\\w*i)', 'g')
const str = `Barfio
Foobar
`;
const subst = `ä`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);