# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/function (.+)\(.*\)\s*\{/$& console.log("$1()");/gm;t' <<< " function example()
{
}
function example2()
{
}"