package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)function (.+)\(.*\)\s*\{`)
var str = ` function example()
{
}
function example2()
{
}`
var substitution = "$& console.log("$1()");"
fmt.Println(re.ReplaceAllString(str, substitution))
}