package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\a-z]+`)
var str = `84 996306412 erico`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}