const regex = /(^[Vv]\d{2}\.*\d{1,2}$)|(^[Ee]\d{3}\.*\d{0,1}$)|(^\d{2,4}$)|(^\d{2}\.*\d{1,2}$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[Vv]\\d{2}\\.*\\d{1,2}$)|(^[Ee]\\d{3}\\.*\\d{0,1}$)|(^\\d{2,4}$)|(^\\d{2}\\.*\\d{1,2}$)', '')
const str = `E8015`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}