$re = '/^[^a-z\'"*&<>\/\n]+$/m';
$str = 'Valid examples:
SITE 10
A23 - FLATS 12B RANGE AND ALLOWANCE PITCH.
2 - 9 GUARDSPACE AVENUE.
Invalid:
site 10
A23 / FLATS 12B RANGE AND ALLOWANCE PITCH
2 & 9 GUARDSPACE AVENUE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);