package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`to (\w+)`)
var str = `to be to see to read`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}