#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$"
Local $sString = "09:00pm" & @CRLF & _
"09:00am" & @CRLF & _
"08:55pm" & @CRLF & _
"08:54am" & @CRLF & _
"10:00pm" & @CRLF & _
"1:00pm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")