package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{1,6}X{0,6}$`)
var str = `123456
123XXX
1XXXXXX
123XXXXXXX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}