#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)([\x{0041}-\x{005A}]{2,})"
Local $sString = "SONYA" & @CRLF & _
"We Want to only replace SONYA and not S O N Y A." & @CRLF & _
""
Local $sSubst = "\L$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)