using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\x{0041}-\x{005A}]{2,})";
string substitution = @"\L$1";
string input = @"SONYA
We Want to only replace SONYA and not S O N Y A.
";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}