package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\x{0041}-\x{005A}]{2,})`)
var str = `SONYA
We Want to only replace SONYA and not S O N Y A.
`
var substitution = "\L$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}