import re
regex = re.compile(r"([\x{0041}-\x{005A}]{2,})", flags=re.UNICODE)
test_str = ("SONYA\n"
"We Want to only replace SONYA and not S O N Y A.\n")
subst = "\\L$1"
result = regex.sub(subst, test_str)
if result:
print(result)