package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).\n`)
var str = `src\Gpac\gpac.exe -i pipe://video:ext=hevc:audelim=true -o stdout:ext=ts:pes_pack=none | src\FFmpeg\ffmpeg_win_x64.exe -hide_banner -y -i - -i I:\BDMV\STREAM\00018.m2ts -map 0:0 -map 1:2 -c copy -bsf:v hevc_metadata=aud=insert -metadata title=
"Transformers_____________________________________"
D:\Transformers.mkv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}