using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,5}(?!\d+)[-\p{L}\d]+$";
string input = @"12345a235
123a
12345-aa1
12345a
12345-a
-11
111111
aaaa
version 1 :: plain ... ^\d{1,5}(?!\d+)[-\p{L}\d]+$
version 2 :: named ... ^(?<digitsOnly>\p{N}{1,5}(?!\p{N}+))(?<miscellaneous>[-\p{L}\p{N}]+)$
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}