// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^\d{1,5}[-\p{L}][-\p{L}\d]{0,9}$").unwrap();
let string = "12345a235
123a
12345-aa1
12345a
12345-a
12-a235dkfsf
12-a235dkfsfs
123a-dssava-y
123a-dssava-1a
12345-aa1--asd-
12345-aa1--asd-s
-11
111111
aaaa
version 1 :: plain ... ^\\d{1,5}[-\\p{L}][-\\p{L}\\d]{0,9}$
version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5})(?<miscellaneous>[-\\p{L}][-\\p{L}\\p{N}]{0,9})$
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}