import Foundation
let pattern = #"\b(^|[a-z0-9\-\—]+)(\s?)(\'|\ʼ|\ʻ|\’)(\s?)((s|d|ll|nt|(t(is?|s?){1,2}){1,3}|((r|v){1}(e?){1}){1,2})\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Rule 1a. Use the apostrophe to show possession. To show possession with a singular noun, add an apostrophe plus the letter s.
Examples:
a woman's hat
the boss's wife
Mrs. Chang's house
Rule 1b. Many common nouns end in the letter s (lens, cactus, bus, etc.). So do a lot of proper nouns (Mr. Jones, Texas, Christmas). There are conflicting policies and theories about how to show possession when writing such nouns. There is no right answer; the best advice is to choose a formula and stay consistent.
Rule 1c. Some writers and editors add only an apostrophe to all nouns ending in s. And some add an apostrophe + s to every proper noun, be it Hastings's or Jones's.
One method, common in newspapers and magazines, is to add an apostrophe + s ('s) to common nouns ending in s, but only a stand-alone apostrophe to proper nouns ending in s.
Examples:
the class's hours
Mr. Jones' golf clubs
the canvas's size
Texas' weather
Care must be taken to place the apostrophe outside the word in question. For instance, if talking about a pen belonging to Mr. Hastings, many people would wrongly write Mr. Hasting's pen (his name is not Mr. Hasting).
Correct: Mr. Hastings' pen
Another widely used technique is to write the word as we would speak it. For example, since most people saying "Mr. Hastings' pen" would not pronounce an added s, we would write Mr. Hastings' pen with no added s. But most people would pronounce an added s in "Jones's," so we'd write it as we say it: Mr. Jones's golf clubs. This method explains the punctuation of for goodness' sake.
Rule 2a. Regular nouns are nouns that form their plurals by adding either the letter s or es (guy, guys; letter, letters; actress, actresses; etc.). To show plural possession, simply put an apostrophe after the s.
Correct: guys' night out (guy + s + apostrophe)
Incorrect: guy's night out (implies only one guy)
Correct: two actresses' roles (actress + es + apostrophe)
Incorrect: two actress's roles
Rule 2b. Do not use an apostrophe + s to make a regular noun plural.
Incorrect: Apostrophe's are confusing.
Correct: Apostrophes are confusing.
Incorrect: We've had many happy Christmas's.
Correct: We've had many happy Christmases.
In special cases, such as when forming a plural of a word that is not normally a noun, some writers add an apostrophe for clarity.
Example: Here are some do's and don't.
In that sentence, the verb do is used as a plural noun, and the apostrophe was added because the writer felt that dos was confusing. Not all writers agree; some see no problem with dos and don'ts.
However, with single lowercase letters, it is advisable to use apostrophes.
Example: My a's look like u's.
Imagine the confusion if you wrote that sentence without apostrophes. Readers would see as and us, and feel lost.
Rule 2c. English also has many irregular nouns (child, nucleus, tooth, etc.). These nouns become plural by changing their spelling, sometimes becoming quite different words. You may find it helpful to write out the entire irregular plural noun before adding an apostrophe or an apostrophe + s.
Incorrect: two childrens' hats
The plural is children, not childrens.
Correct: two children's hats (children + apostrophe + s)
Incorrect: the teeths' roots
Correct: the teeth's roots
Rule 2d. Things can get really confusing with the possessive plurals of proper names ending in s, such as Hastings and Jones.
If you're the guest of the Ford family—the Fords—you're the Fords' guest (Ford + s + apostrophe). But what if it's the Hastings family?
Most would call them the "Hastings." But that would refer to a family named "Hasting." If someone's name ends in s, we must add -es for the plural. The plural of Hastings is Hastingses. The members of the Jones family are the Joneses.
To show possession, add an apostrophe.
Incorrect: the Hastings' dog
Correct: the Hastingses' dog (Hastings + es + apostrophe)
Incorrect: the Jones' car
Correct: the Joneses' car
In serious writing, this rule must be followed no matter how strange or awkward the results.
Rule 2e. Never use an apostrophe to make a name plural.
Incorrect: The Wilson's are here.
Correct: The Wilsons are here.
Incorrect: We visited the Sanchez's.
Correct: We visited the Sanchezes.
Rule 3. With a singular compound noun (for example, mother-in-law), show possession with an apostrophe + s at the end of the word.
Example: my mother-in-law's hat
If the compound noun (e.g., brother-in-law) is to be made plural, form the plural first (brothers-in-law), and then use the apostrophe + s.
Example: my two brothers-in-law's hats
Rule 4a. If two people possess the same item, put the apostrophe + s after the second name only.
Example: Cesar and Maribel's home is constructed of redwood.
However, if one of the joint owners is written as a pronoun, use the possessive form for both.
Incorrect: Maribel and my home
Incorrect: Mine and Maribel's home
Correct: Maribel's and my home
Incorrect: he and Maribel's home
Incorrect: him and Maribel's home
Correct: his and Maribel's home
Incorrect: you and Maribel's home
Incorrect: yours and Maribel's home
Correct: Maribel's and your home
Note: As the above examples demonstrate, when one of the co-owners is written as a pronoun, use possessive adjectives (my, your, her, our, their). Avoid possessive pronouns (mine, yours, hers, ours, theirs) in such constructions.
It should be mentioned that compound possessives are often clunky as well as confusing. For instance, a picture of her and Cesar's house could refer to a photo of "her" in front of the house that Cesar owns or a photo of the house that she and Cesar co-own. Big difference. Such ambiguous sentences should just be rewritten.
Rule 4b. In cases of separate rather than joint possession, use the possessive form for both.
Examples:
Cesar's and Maribel's homes are both lovely.
They don't own the homes jointly.
Cesar and Maribel's homes are both lovely.
The homes belong to both of them.
Rule 5. Use an apostrophe with contractions. The apostrophe is placed where a letter or letters have been removed.
Examples: doesn't, it's, 'tis, can't, you'd, should've, rock 'n' roll, etc.
Incorrect: does'nt
Rule 6. There are various approaches to plurals for abbreviations, single letters, and numerals.
Many writers and editors prefer an apostrophe after single capitalized letters.
Example: I made straight A's.
With groups of two or more capital letters, apostrophes seem less necessary.
Examples:
There are two new MPs on the base.
He learned his ABCs.
She consulted with three M.D.s. OR She consulted with three M.D.'s.
Some write M.D.'s to give the s separation from the second period.
Single-digit numbers are usually spelled out, but when they aren't, you are just as likely to see 2s and 3s as 2's and 3's. With double digits and above, many (but not everyone) regard the apostrophe as superfluous: I scored in the high 90s.
There are different schools of thought about years and decades. The following examples are all in widespread use:
Examples:
the 1990s
the 1990's
the '90s
the 90's
Awkward: the '90's
Rule 7. Amounts of time or money are sometimes used as possessive adjectives that require apostrophes.
Incorrect: three days leave
Correct: three days' leave
Incorrect: my two cents worth
Correct: my two cents' worth
Rule 8. The personal pronouns hers, ours, yours, theirs, its, whose, and the pronoun oneself never take an apostrophe.
Examples:
Correct: Feed a horse grain. It's better for its health.
Incorrect: Who's glasses are these?
Correct: Whose glasses are these?
Incorrect: Talking to one's self in public is odd.
Correct: Talking to oneself in public is odd.
Rule 9. When an apostrophe comes before a word or number, take care that it's truly an apostrophe (’) rather than a single quotation mark (‘).
Incorrect: ‘Twas the night before Christmas.
Correct: ’Twas the night before Christmas.
Incorrect: I voted in ‘08.
Correct: I voted in ’08.
NOTE
Serious writers avoid the word 'til as an alternative to until. The correct word is till, which is many centuries older than until.
Rule 10. Beware of false possessives, which often occur with nouns ending in s. Don't add apostrophes to noun-derived adjectives ending in s. Close analysis is the best guide.
Incorrect: We enjoyed the New Orleans' cuisine.
In the preceding sentence, the word the makes no sense unless New Orleans is being used as an adjective to describe cuisine. In English, nouns frequently become adjectives. Adjectives rarely if ever take apostrophes.
Incorrect: I like that Beatles' song.
Correct: I like that Beatles song.
Again, Beatles is an adjective, modifying song.
Incorrect: He's a United States' citizen.
Correct: He's a United States citizen.
Rule 11. Beware of nouns ending in y; do not show possession by changing the y to ies.
Correct: the company's policy
Incorrect: the companies policy
To show possession when a noun ending in y becomes plural, write ies'. Do not write y's.
Correct: three companies' policies
Incorrect: three company's policies
Exception: Names and other proper nouns ending in y become plural simply by adding an s. They do not form their plurals with an apostrophe, or by changing the y to ies.
Correct: The Flannerys are coming over.
Incorrect: The Flannery's are coming over.
Incorrect: The Flanneries are coming over.
Correct: The Flannerys' house was robbed.
Incorrect: The Flanneries' house was robbed.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)