using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([^\[]+)\[([^\]]+)\])";
string input = @"/foo/firstName[firstId]/optional1[oId1]/optional2[oId2]/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}