package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:([^\[]+)\[([^\]]+)\])`)
var str = `/foo/firstName[firstId]/optional1[oId1]/optional2[oId2]/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}