const regex = /(?<!\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\s+)(\w)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\\s+)(\\w)', 'gi')
const str = `U.S.A. is the country? i want to live in. if you please. yes. nope.
U.S.A. is the country? i want to live inc. if you pease. dope. yes.
U.S.A. is the country? i want to live Inc. if you pease. dope. yes.
u.s.w. and so on. a German abbreviation.
U.s.w. and so on. a German abbreviation.
// str
// .replace(
// (/(?<!\\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\\s+)(\\w)/gi),
// (_, \$1, \$2) => \$1 + \$2.toUpperCase()
// );
// ... or ...
// str
// .replace(
// (/(?<!inc|pease|nope|U.S.A|u.s.w)([.?!]\\s*)(\\w)/gi),
// (_, \$1, \$2) => \$1 + \$2.toUpperCase()
// )
// .replace((/U\\.S\\.W\\./g), 'u.s.w.');
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);