use strict;
my $str = 'U.S.A. is the country? i want to live in. if you please. yes. nope.
U.S.A. is the country? i want to live inc. if you pease. dope. yes.
U.S.A. is the country? i want to live Inc. if you pease. dope. yes.
u.s.w. and so on. a German abbreviation.
U.s.w. and so on. a German abbreviation.
// str
// .replace(
// (/(?<!\\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\\s+)(\\w)/gi),
// (_, $1, $2) => $1 + $2.toUpperCase()
// );
// ... or ...
// str
// .replace(
// (/(?<!inc|pease|nope|U.S.A|u.s.w)([.?!]\\s*)(\\w)/gi),
// (_, $1, $2) => $1 + $2.toUpperCase()
// )
// .replace((/U\\.S\\.W\\./g), \'u.s.w.\');
';
my $regex = qr/(?<!\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\s+)(\w)/ip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";