#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!\.bin\.js$).)+\.js$"
Local $sString = "I want to match the following:" & @CRLF & _
"" & @CRLF & _
"file1.js" & @CRLF & _
"file2.src.js" & @CRLF & _
"file3.bin.src.js" & @CRLF & _
"" & @CRLF & _
"But not:" & @CRLF & _
"" & @CRLF & _
"file1.bin.js" & @CRLF & _
"file2.src.bin.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")