Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:(?:[^\s\d\x2e]+[\s\d\x2e]*)|(?:[\x2e\s\d]*[^\s\x2e\d]+))[\r\n]
/
Input 1
1
New
2222.22.22.22 asd