#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!-- InstanceBeginEditable name="cat" -->(.*)<!-- InstanceEndEditable -->"
Local $sString = "<!-- InstanceBeginEditable name="cat" -->Properties of Matter <!-- InstanceEndEditable -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")