#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[[+-]?([048]|\d*([02468][048]|[13579][26]))\]"
Local $sString = ""[+05620]" // 5620 is divisible by 4 (valid)" & @CRLF & _
""[+05621]" // 5621 is not divisible by 4 (invalid)" & @CRLF & _
""[-55622]" // -55622 is not divisible by 4 (invalid)" & @CRLF & _
""[005623]" // 5623 invalid" & @CRLF & _
""[005624]" // 5624 valid" & @CRLF & _
""[-05628]" // valid" & @CRLF & _
""[005632]" // valid" & @CRLF & _
""[555636]" // valid" & @CRLF & _
""[+05640]" // valid" & @CRLF & _
""[005600]" // valid" & @CRLF & _
""[8.04]" // invalid" & @CRLF & _
""[8.00]" // valid" & @CRLF & _
"" & @CRLF & _
""[-0]"" & @CRLF & _
""...may be [+002016] will be."" & @CRLF & _
"" & @CRLF & _
""[+05621]", "[-55622]", " & @CRLF & _
""[005623]", "[~24]", "[8.04]", " & @CRLF & _
""No, [2014] isn't a multiple of 4..."" & @CRLF & _
"" & @CRLF & _
""[0]"" & @CRLF & _
""[4]"" & @CRLF & _
""[8]"" & @CRLF & _
""[12]"" & @CRLF & _
""[16]"" & @CRLF & _
""[20]"" & @CRLF & _
""[24]"" & @CRLF & _
""[28]"" & @CRLF & _
""[32]"" & @CRLF & _
""[36]"" & @CRLF & _
""[40]"" & @CRLF & _
""[44]"" & @CRLF & _
""[48]"" & @CRLF & _
""[52]"" & @CRLF & _
""[56]"" & @CRLF & _
""[60]"" & @CRLF & _
""[64]"" & @CRLF & _
""[68]"" & @CRLF & _
""[72]"" & @CRLF & _
""[76]"" & @CRLF & _
""[80]"" & @CRLF & _
""[84]"" & @CRLF & _
""[88]"" & @CRLF & _
""[92]"" & @CRLF & _
""[96]"" & @CRLF & _
""[100]"" & @CRLF & _
""[104]"" & @CRLF & _
""[108]"" & @CRLF & _
""[112]"" & @CRLF & _
""[116]"" & @CRLF & _
""[120]"" & @CRLF & _
""[124]"" & @CRLF & _
""[128]"" & @CRLF & _
"" & @CRLF & _
""[1]"" & @CRLF & _
""[2]"" & @CRLF & _
""[3]"" & @CRLF & _
""[5]"" & @CRLF & _
""[6]"" & @CRLF & _
""[7]"" & @CRLF & _
""[9]"" & @CRLF & _
""[10]"" & @CRLF & _
""[11]"" & @CRLF & _
""[13]"" & @CRLF & _
""[14]"" & @CRLF & _
""[15]"" & @CRLF & _
""[17]"" & @CRLF & _
""[18]"" & @CRLF & _
""[19]"" & @CRLF & _
""[21]"" & @CRLF & _
""[22]"" & @CRLF & _
""[23]"" & @CRLF & _
""[25]"" & @CRLF & _
""[26]"" & @CRLF & _
""[27]"" & @CRLF & _
""[29]"" & @CRLF & _
""[30]"" & @CRLF & _
""[31]"" & @CRLF & _
""[33]"" & @CRLF & _
""[34]"" & @CRLF & _
""[35]"" & @CRLF & _
""[37]"" & @CRLF & _
""[38]"" & @CRLF & _
""[39]"" & @CRLF & _
""[41]"" & @CRLF & _
""[42]"" & @CRLF & _
""[43]"" & @CRLF & _
""[45]"" & @CRLF & _
""[46]"" & @CRLF & _
""[47]"" & @CRLF & _
""[49]"" & @CRLF & _
""[50]"" & @CRLF & _
""[51]"" & @CRLF & _
""[53]"" & @CRLF & _
""[54]"" & @CRLF & _
""[55]"" & @CRLF & _
""[57]"" & @CRLF & _
""[58]"" & @CRLF & _
""[59]"" & @CRLF & _
""[61]"" & @CRLF & _
""[62]"" & @CRLF & _
""[63]"" & @CRLF & _
""[65]"" & @CRLF & _
""[66]"" & @CRLF & _
""[67]"" & @CRLF & _
""[69]"" & @CRLF & _
""[70]"" & @CRLF & _
""[71]"" & @CRLF & _
""[73]"" & @CRLF & _
""[74]"" & @CRLF & _
""[75]"" & @CRLF & _
""[77]"" & @CRLF & _
""[78]"" & @CRLF & _
""[79]"" & @CRLF & _
""[81]"" & @CRLF & _
""[82]"" & @CRLF & _
""[83]"" & @CRLF & _
""[85]"" & @CRLF & _
""[86]"" & @CRLF & _
""[87]"" & @CRLF & _
""[89]"" & @CRLF & _
""[90]"" & @CRLF & _
""[91]"" & @CRLF & _
""[93]"" & @CRLF & _
""[94]"" & @CRLF & _
""[95]"" & @CRLF & _
""[97]"" & @CRLF & _
""[98]"" & @CRLF & _
""[99]"" & @CRLF & _
""[101]"" & @CRLF & _
""[102]"" & @CRLF & _
""[103]"" & @CRLF & _
""[105]"" & @CRLF & _
""[106]"" & @CRLF & _
""[107]"" & @CRLF & _
""[109]"" & @CRLF & _
""[110]"" & @CRLF & _
""[111]"" & @CRLF & _
""[113]"" & @CRLF & _
""[114]"" & @CRLF & _
""[115]"" & @CRLF & _
""[117]"" & @CRLF & _
""[118]"" & @CRLF & _
""[119]"" & @CRLF & _
""[121]"" & @CRLF & _
""[122]"" & @CRLF & _
""[123]"" & @CRLF & _
""[125]"" & @CRLF & _
""[126]"" & @CRLF & _
""[127]"" & @CRLF & _
""[129]"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"4" & @CRLF & _
"8" & @CRLF & _
"12" & @CRLF & _
"16" & @CRLF & _
"20" & @CRLF & _
"24" & @CRLF & _
"28" & @CRLF & _
"32" & @CRLF & _
"36" & @CRLF & _
"40" & @CRLF & _
"44" & @CRLF & _
"48" & @CRLF & _
"52" & @CRLF & _
"56" & @CRLF & _
"60" & @CRLF & _
"64" & @CRLF & _
"68" & @CRLF & _
"72" & @CRLF & _
"76" & @CRLF & _
"80" & @CRLF & _
"84" & @CRLF & _
"88" & @CRLF & _
"92" & @CRLF & _
"96" & @CRLF & _
"100" & @CRLF & _
"104" & @CRLF & _
"108" & @CRLF & _
"112" & @CRLF & _
"116" & @CRLF & _
"120" & @CRLF & _
"124" & @CRLF & _
"128" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"13" & @CRLF & _
"14" & @CRLF & _
"15" & @CRLF & _
"17" & @CRLF & _
"18" & @CRLF & _
"19" & @CRLF & _
"21" & @CRLF & _
"22" & @CRLF & _
"23" & @CRLF & _
"25" & @CRLF & _
"26" & @CRLF & _
"27" & @CRLF & _
"29" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"33" & @CRLF & _
"34" & @CRLF & _
"35" & @CRLF & _
"37" & @CRLF & _
"38" & @CRLF & _
"39" & @CRLF & _
"41" & @CRLF & _
"42" & @CRLF & _
"43" & @CRLF & _
"45" & @CRLF & _
"46" & @CRLF & _
"47" & @CRLF & _
"49" & @CRLF & _
"50" & @CRLF & _
"51" & @CRLF & _
"53" & @CRLF & _
"54" & @CRLF & _
"55" & @CRLF & _
"57" & @CRLF & _
"58" & @CRLF & _
"59" & @CRLF & _
"61" & @CRLF & _
"62" & @CRLF & _
"63" & @CRLF & _
"65" & @CRLF & _
"66" & @CRLF & _
"67" & @CRLF & _
"69" & @CRLF & _
"70" & @CRLF & _
"71" & @CRLF & _
"73" & @CRLF & _
"74" & @CRLF & _
"75" & @CRLF & _
"77" & @CRLF & _
"78" & @CRLF & _
"79" & @CRLF & _
"81" & @CRLF & _
"82" & @CRLF & _
"83" & @CRLF & _
"85" & @CRLF & _
"86" & @CRLF & _
"87" & @CRLF & _
"89" & @CRLF & _
"90" & @CRLF & _
"91" & @CRLF & _
"93" & @CRLF & _
"94" & @CRLF & _
"95" & @CRLF & _
"97" & @CRLF & _
"98" & @CRLF & _
"99" & @CRLF & _
"101" & @CRLF & _
"102" & @CRLF & _
"103" & @CRLF & _
"105" & @CRLF & _
"106" & @CRLF & _
"107" & @CRLF & _
"109" & @CRLF & _
"110" & @CRLF & _
"111" & @CRLF & _
"113" & @CRLF & _
"114" & @CRLF & _
"115" & @CRLF & _
"117" & @CRLF & _
"118" & @CRLF & _
"119" & @CRLF & _
"121" & @CRLF & _
"122" & @CRLF & _
"123" & @CRLF & _
"125" & @CRLF & _
"126" & @CRLF & _
"127" & @CRLF & _
"129"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")