using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b[_a-zA-Z]|\B\$)[_$a-zA-Z0-9]*+";
string input = @"aaa
sales_tax
_circleArea
box100width
$directory
ab1234$$
$alpha$";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}