import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b[_a-zA-Z]|\\B\\$)[_$a-zA-Z0-9]*+";
final String string = "aaa\n"
+ "sales_tax\n"
+ "_circleArea\n"
+ "box100width\n"
+ "$directory\n"
+ "ab1234$$\n"
+ "$alpha$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}