$re = '/(?:\b[_a-zA-Z]|\B\$)[_$a-zA-Z0-9]*+/';
$str = 'aaa
sales_tax
_circleArea
box100width
$directory
ab1234$$
$alpha$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);