using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n\s?-\s?(.*)";
string input = @"Lorem ipsum.
- item 1
- item 2
- item 3
- item 4
Dolores amet.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}