package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n\s?-\s?(.*)`)
var str = `Lorem ipsum.
- item 1
- item 2
- item 3
- item 4
Dolores amet.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}