$re = '/(\(\s*([a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|\*|\/|\+|\-|==|!=|>|>=|<|<=)\s*([a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*\))/m';
$str = '(a in b)
(a ni b)
(a in [1,2,3])
([1,2,3] == [1,2,3])
(a == \'Ahmad Hajjar\')
((a+1)==b)
(1==1)
( a == a)
(1==2)
(x1!=y)
(xa1*3)
((7*3)==21)
((17*9)!=(a+b))
((( a + b )*(c-d))==(5/2))
( a+b)
( a - b)
( a/b )
( a * b )
(ahmad>feras)
(ahmad>=feras)
(feras<ahmad)
(feras<=ahmad)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);