#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!LTD|LIMITED)\b\w+\b"
Local $sString = "ABC" & @CRLF & _
"ABC LTD" & @CRLF & _
"ABC LTD UK" & @CRLF & _
"LTD ABC" & @CRLF & _
"LTD UK ABC LIMITED"
Local $sSubst = ""$1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)