import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!LTD|LIMITED)\\b\\w+\\b";
final String string = "ABC\n"
+ "ABC LTD\n"
+ "ABC LTD UK\n"
+ "LTD ABC\n"
+ "LTD UK ABC LIMITED";
final String subst = "\"$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}