const regex = /(?!LTD|LIMITED)\b\w+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!LTD|LIMITED)\\b\\w+\\b', 'gm')
const str = `ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED`;
const subst = `"$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);