re = /(?!LTD|LIMITED)\b\w+\b/m
str = 'ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result