using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\(([[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*,){5}[[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*\)";
string input = @"lc_checkout(int job, feature, version, nlic, flag, key )";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}