const regex = /.*\(([[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*,){5}[[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\(([[:blank:]]*[[:alnum:]]*[[:blank:]]*\\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*,){5}[[:blank:]]*[[:alnum:]]*[[:blank:]]*\\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*\\)', '')
const str = `lc_checkout(int job, feature, version, nlic, flag, key )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}