const regex = new RegExp('[0-9]{8}.csv', '')
const str = `SEI_Crestline_Local_Position_Appraisal_05082015.csv
BB.upload.06102106.csv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}