$re = '/GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+"/';
$str = 'GRUB_CMDLINE_LINUX="cgroup_enable=memory foo=bar swapaccount=1 lala=moo"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);