# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(lang=)[^&#]*/$1en/g;t' <<< "http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue"