package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(lang=)[^&#]*`)
var str = `http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue`
var substitution = "$1en"
fmt.Println(re.ReplaceAllString(str, substitution))
}