// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(lang=)[^&#]*").unwrap();
let string = "http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue";
let substitution = "$1en";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}