$re = '/[0-9]{1,2}(:[0-9]{1,2}){2}(?=\sGMT)/';
$str = 'located on 10/6/2015 5:18:14 GMT';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);