#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)"
Local $sString = "We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did" & @CRLF & _
"" & @CRLF & _
"Excerpt from: "2 Samuel: Your Kingdom Come" by John Woodhouse. Scribd." & @CRLF & _
"This material may be protected by copyright." & @CRLF & _
"" & @CRLF & _
"Read this book on Scribd: https://www.scribd.com/book/284612094" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")