using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)";
string input = @"We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did
Excerpt from: ""2 Samuel: Your Kingdom Come"" by John Woodhouse. Scribd.
This material may be protected by copyright.
Read this book on Scribd: https://www.scribd.com/book/284612094
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}