import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:.|\\n)*)\\n\\nExcerpt(?:(?:.|\\n)*)";
final String string = "We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did\n\n"
+ "Excerpt from: \"2 Samuel: Your Kingdom Come\" by John Woodhouse. Scribd.\n"
+ "This material may be protected by copyright.\n\n"
+ "Read this book on Scribd: https://www.scribd.com/book/284612094\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}