const regex = /((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:.|\\n)*)\\n\\nExcerpt(?:(?:.|\\n)*)', 'gm')
const str = `We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did
Excerpt from: "2 Samuel: Your Kingdom Come" by John Woodhouse. Scribd.
This material may be protected by copyright.
Read this book on Scribd: https://www.scribd.com/book/284612094
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}