$re = '/((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)/m';
$str = 'We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did
Excerpt from: "2 Samuel: Your Kingdom Come" by John Woodhouse. Scribd.
This material may be protected by copyright.
Read this book on Scribd: https://www.scribd.com/book/284612094
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);